Planning Analytics Version Management

Planning Analytics server (TM1 server), Planning Analytics Workspace (PAW) and Planning Analytics for Excel (PAX) are all regularly updated by IBM. It is really important to keep the version in sync because otherwise, the different components will not work together properly.

Think about it like this. If PAX expects a certain response from PAW when you, say open the set editor, and that response is unable to be returned by PAW, PAX is going to fail. Likewise, if PAW expects PA server to respond in one way and PA doesn’t know about it, well it ain’t gonna work!

Just to make it a little complex, PAX and PAW are on a release cycle of about one release each month, while PA (TM1) server is on a release cycle of about one release each quarter.

IBM’s Requirements for TM1 Versions

IBM has a table that refers to TM1 versions that need to be used for the ecosystem to work nicely. You can find it here. It is pretty complicated, somewhat counterintuitive and almost contradictory. The essence of this IBM blog post is as follows:

Version of PAW to use with PAX

The version of PAW to use with PAX is the same version number or one above or one below. For example, if you have PAX version 2.0.50 installed, then use PAW version 2.0.49, 2.0.50 or 2.0.51.

Version of PAX to use with PAW

The version of PAX that is supported with PAW is the matching release or the three prior releases. Therefore, if you say have version 2.0.49 of PAW, then you can install PAX version 2.0.49, 2.0.48, 2.0.47 or 2.0.46.

This seems a bit counterintuitive though, doesn’t it? Why aren’t they the reverse, I hear you ask. Apparently this is because the support versions are, what IBM call, “directional”. So there are things in PAX that require certain features in PAW to work, and stuff in PAW that needs features in PAX.

Bidirectional Conformance between PAX and PAW Versions

To ensure bidirectional conformance, use the matching or one prior version in from PAW and PAX, or one plus version, the matching or one prior from PAX to PAW. For example use from PAW 2.0.48, use PAX 2.0.48 or 2.0.47; or from PAX 2.0.49, use PAW 2.0.50, 2.0.49 or 2.0.48.

Clear as mud, isn’t it! I think the best recommendation is just to keep them in sync.

Version of PA (TM1) Server to use with PAW

The version of TM1 server one is a little more difficult because of the slower release cadence. IBM advises that you should use either the version of PA server that was packaged with the PAW or PAX or the two prior versions. Therefore, if you have installed PAX 2.0.50 and that was bundled with Planning Analytics 2.0.9, then you must use either PA 2.0.9, 2.0.8 or 2.0.7. Any earlier than that is not a supported mix.

You might also like

Also in the series